This is the mail archive of the mailing list for the Cygwin project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

rsync to between workgroups

I recently setup rsync over ssh to syncronize two external web servers with an internal staging server. The rsync works fine but the permissions on the external boxes get hosed everytime it runs.

The internal server is a win2k box that is a domain member. The two external web servers are NT4 standalone servers in different workgroups.

My goal is to simply syncronize all of the directories/files with the staging server and leave all of the permissions on the external servers untouched. In other words, I want to push-out updated versions of the root web folder but have those folders retain their settings at the remote ends. I would like any new files created on the internal box to ultimately inherit the rights of the external wwroot folder on the external boxes. Incidentally, this folder gives full control to Admins, Change for a powerUser named "WebAdmin" and Read permissions to the Everyone group.

Since all of these machines have different user and machine SIDS, I realize that I'll never be able to preserve permissions, so I'm not using the -p or -a switches for rsync.

I've done a mkpasswd -l > /etc/passwd and mkgroup -l /etc/group on both external boxes. I also have edited the passwd file to replace group GID 513 with the appropriate IDs for the Administrator and PowerUser accounts.

I've tried using CYGWIN=ntsec and CYGWIN=nontsec. Doesn't seem to make a difference.

Each time I run the rsync, I end up with permissions like CREATOR OWNER (ALL), CREATOR GROUP(RX), WebAdmin Special Access(RWXD), EVERYONE Read (RX), USERS Special Access(RX). These are not the permissions that existed before the rsync. I want the permissions to stay the same.

I don't think this is an rsync issue as I've noticed similar behavior if I just touch a new file from an ssh session on one of the external boxes.

The manual discusses permissions but it doesn't seem to addresss this scenario directly. I've been reading the posts here all day but I don't see anything like this.

How can I get files into a directory without CYGWIN adjusting the permissions?

Thanks for the help!


-- Unsubscribe info: Problem reports: Documentation: FAQ:

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]