This is the mail archive of the mailing list for the Cygwin project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: telnet, ftp unknown service


I noticed that cygwin telnet works when I specify the port to use in the
command line like this :
telnet <hosts> 23.
So I presumed it was a problem with my "services" file, I took the one of a
colleague (where cygwin telnet works correctly) but it's still the same.
Please, any help is welcome, I am desperate.

Vincent Dutat.

"Corinna Vinschen" <> wrote in message">
> On Thu, Oct 02, 2003 at 02:19:36PM +0200, V D wrote:
> > here is the result of strace on a telnet, if you need specifically on
> > just let me know.
> Well, the strace is a bit confusing.  The error returned from
> WinSocks getservbyname function is 11004.  The meaning is according
> to `net helpmsg':
>   "The requested name is valid and was found in the database, but it
>     does not have the correct associated data being resolved for."
> a message, I don't quite understand.  I tried if it could be a binary
> vs. textmode issue but Winsock reads the services file in both variations
> equally well, at least on my XP system.
> Please check your services file.  Is it somehow corrupted?
> Corinna
> -- 
> Corinna Vinschen                  Please, send mails regarding Cygwin to
> Cygwin Developer                      
> Red Hat, Inc.

Unsubscribe info:
Problem reports:

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]