This is the mail archive of the mailing list for the Cygwin project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

dpkg --info crashes / dpkg-deb --info hangs

I ran into a problem using dpkg, like this:

$ dpkg --info dpkg_1.9.21_i386.deb
Segmentation fault (core dumped)

I can send the .stackdump file if it's interesting, but I'm running into the
100K limit.

Since dpkg --info is pretty close to dpkg-deb --info, I tried that next.

$ dpkg-deb --info dpkg_1.9.21_i386.deb
 new debian package, version 2.0.
 size 1073426 bytes: control archive= zi bytes.
      72 bytes,     3 lines      conffiles
     857 bytes,    23 lines      control
    5675 bytes,   240 lines   *  postinst             #!/bin/sh
      86 bytes,    10 lines   *  postrm               #!/bin/sh
    2423 bytes,    86 lines   *  preinst              #!/bin/sh
     442 bytes,    20 lines   *  prerm                #!/bin/sh
 Package: dpkg
 Version: 1.9.21
 Section: base
 Priority: required
 Architecture: i386
 Essential: yes
 Pre-Depends: libc6 (>= 2.2.4-4), libncurses5 (>= 5.2.20020112a-1),
libstdc++2.10-glibc2.2 (>= 1:2.95.4-0.010810)
 Conflicts: sysvinit (<< 2.80)
 Replaces: dpkg-doc-ja
 Installed-Size: 2840
 Origin: debian
 Maintainer: Dpkg Development <>
 Bugs: debbugs://
 Description: Package maintenance system for Debian
  This package contains the programs which handle the installation and
  removal of packages on your system.
  The primary interface for the dpkg suite is the `dselect' program;
  a more low-level and less user-friendly interface is available in
  the form of the `dpkg' command.
  In order to unpack and build Debian source packages you will need to
  install the developers' package `dpkg-dev' as well as this one.

This seems OK, except for a few things:

- I don't get a prompt back.
- There's an rm process running that is eating up all my CPU.
- The size of the control archive isn't really zi bytes.

If I kill the rm process via the task manager, the message:

rm cleanup failed, code 256

appears, and I get my prompt back.  At that point, echo $? displays 0.

I got the package from by
clicking on the Go To Download Page button at the bottom.  I get the same
results for other packages I built with my own two hands.

I went ahead and got the source (dpkg-1.10.4-1), and built it using the script (mkdirs prep conf build install).  The output of the
dpkg-deb I built by hand is the same as the one in the package.  The stack
trace is for the dpkg binary I installed with setup.


$ dpkg-deb --contents dpkg_1.9.21_i386.deb

works fine.

$ dpkg --contents dpkg_1.9.21_i386.deb

crashes the same way dpkg --info does.  Again, both the setup-installed
binaries, and the ones I built from source behave the same way.

$ strace dpkg-deb --info dpkg_1.9.21_i386.deb >

also hangs.  I'll send the strace file in another post so the mailing list
software will take it.  There appears to be some kind of infinite loop in

dpkg-deb is creating a directory in /tmp (e. g. /tmp/dpkg610ca768.0) which
remains after I terminate rm.  The directory is empty as far as I can tell.
Perhaps this is interesting info:

DByron@DByron /usr/src/dpkg-1.10.4/dpkg-deb
$ ls -l /tmp/dpkg610ca768.0/
total 0

DByron@DByron /usr/src/dpkg-1.10.4/dpkg-deb
$ getfacl /tmp/dpkg610ca768.0/
# file: /tmp/dpkg610ca768.0/
# owner: DByron
# group: SYSTEM

Thanks much for any help you can provide.


Attachment: cygcheck.txt
Description: Text document

Unsubscribe info:
Problem reports:

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]